Repport Bug !!!

Ici nous pouvons essayé de remonter les bug's qui ce déclare à l'usage. Certain existe déjà et son connue, d'autre pas forcement des bug's mais des améliorations et certains, plus rare, sont des réels bug’s visible à l'usage.

Réponses

  • J'ai découvert un bug qui n'est pas vraiment un bug mais plutôt un oublie ou une omission dans le code ISPConfig.
    Mon collègues à chercher pendant des heures ce problèmes même avec une bonne expérience en "troubleshooting".

    Je vais essayer de vous donnée les éléments pour reproduire le bug sur vos serveurs Test.

    ISPConfig Version: 2.2.15.

    Que nous utilisons en production avec +- 40 sites et 60 domaines.
    Nous disposons d'un serveur principal et deux serveur en backup ISPConfig (juste pour NS et relay-MX).

    Alors comment reproduire le Bug :

    Pré requis : SUExec doit être actif sur l'apache2. Ce qui est mon cas, C-à-d que chaque groupe ISPConfig (chaque site) à son instance apache propre avec ces propres droit d'accès.

    Crée un site avec le portail ISPConfig avec création du domaine (ex: ispxxx.com), jusqu'ici tout va bien. Il crée l'entrer DNS Master et le VHOst.
    Maintenant, click sur le site en question et ajout une directive apache avec une erreur de syntaxe. Type User =

    Ce qu'il ce passe : L'ispconfig doit ré-écrire tout le Vhost (d'ailleurs dommage, je préfère 1 Vhost par site, mais bon...). Il bloque à la syntax error, il ne passe pas au dessus et reviens à la version précédente de son Vhost sans message et sans error log dans /var/log/

    A priori c'est pas trop grave mais si j'ai crée un site juste avant de modifier ma directive apache pour le site ispxxx.com. Et bien, je perte la config Vhost du site que j'ai crée juste avant la modif de la directive apache2.

    La seul manière de voir qu'il y a un prb. c'est le log de ISPConfig /home/admispconf/ispconfig/ispconfiog.log avec juste un petit message d'erreur qui n'est pas claire.

    En gros, c'est null qu'il renvois vers une dev/null et un Check syntax Ok, si pas Ok il revient à la version précédente de la config sans plus de précisions.
    Ex : WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2419: WARNING: could not httpd -t &> /dev/null

    OneKid0
  • Effectivement,

    Mais la dernier fois que j'ai lancer un update j'ai u beaucoup de soucis. J'ai chercher mais je n'est pas trouver ce bug comme déclarer ou corriger. Nous allons bientôt effectuer un update sur notre serveur en labo avant.

    Merci.
Connectez-vous ou Inscrivez-vous pour répondre.